const regex = /(ObjectDatabase|GSRoot)Test\.exe/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(ObjectDatabase|GSRoot)Test\\.exe', 'gm')
const str = `ARCHICADAPITest.exe
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);