$re = '/(ObjectDatabase|GSRoot)Test\.exe/m';
$str = 'ARCHICADAPITest.exe
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;