use strict;
my $str = 'ARCHICADAPITest.exe
';
my $regex = qr/(ObjectDatabase|GSRoot)Test\.exe/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";