using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([1-9]|[1-8][0-9]|9[0-9]|100|3[0-4][0-9]|350)";
string input = @"9
10
11
12
20
30
40
50
60
70
80
90
100
300
320
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}