$re = '/([1-9]|[1-8][0-9]|9[0-9]|100|3[0-4][0-9]|350)/m';
$str = '9
10
11
12
20
30
40
50
60
70
80
90
100
300
320
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);