// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([1-9]|[1-8][0-9]|9[0-9]|100|3[0-4][0-9]|350)").unwrap();
let string = "9
10
11
12
20
30
40
50
60
70
80
90
100
300
320
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}