import re
regex = re.compile(r"([1-9]|[1-8][0-9]|9[0-9]|100|3[0-4][0-9]|350)", flags=re.MULTILINE)
test_str = ("9\n"
"10\n"
"11\n"
"12\n"
"20\n"
"30\n"
"40\n"
"50\n"
"60\n"
"70\n"
"80\n"
"90\n"
"100\n"
"300\n"
"320\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")