import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([1-9]|[1-8][0-9]|9[0-9]|100|3[0-4][0-9]|350)";
final String string = "9\n"
+ "10\n"
+ "11\n"
+ "12\n"
+ "20\n"
+ "30\n"
+ "40\n"
+ "50\n"
+ "60\n"
+ "70\n"
+ "80\n"
+ "90\n"
+ "100\n"
+ "300\n"
+ "320\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}