package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\\(?:xn|[brw]))*([^\r\n]+)\r?\n`)
var str = `\xn[Lan]Allez, il faut se dépécher, RED !
\xn[Lan]Allez, il faut se dépécher, RED !
\bI'll stay here, then
\rFirst, you should restore your Pokémon to full health.
\rFirst, you should restore your Pokémon to full health.
\w[signskin]Once you save your game, you can access the Mystery Gift.
\w[signskin]Once you save your game, you can access the Mystery Gift.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}