const regex = /(?:\\(?:xn|[brw]))*([^\r\n]+)\r?\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\\\(?:xn|[brw]))*([^\\r\\n]+)\\r?\\n', 'g')
const str = `\\xn[Lan]Allez, il faut se dépécher, RED !
\\xn[Lan]Allez, il faut se dépécher, RED !
\\bI'll stay here, then
\\rFirst, you should restore your Pokémon to full health.
\\rFirst, you should restore your Pokémon to full health.
\\w[signskin]Once you save your game, you can access the Mystery Gift.
\\w[signskin]Once you save your game, you can access the Mystery Gift.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}