// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:\\(?:xn|[brw]))*([^\r\n]+)\r?\n").unwrap();
let string = "\\xn[Lan]Allez, il faut se dépécher, RED !
\\xn[Lan]Allez, il faut se dépécher, RED !
\\bI'll stay here, then
\\rFirst, you should restore your Pokémon to full health.
\\rFirst, you should restore your Pokémon to full health.
\\w[signskin]Once you save your game, you can access the Mystery Gift.
\\w[signskin]Once you save your game, you can access the Mystery Gift.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}