# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\\(?:xn|[brw]))*([^\r\n]+)\r?\n"
test_str = ("\\xn[Lan]Allez, il faut se dépécher, RED !\n"
"\\xn[Lan]Allez, il faut se dépécher, RED !\n"
"\\bI'll stay here, then\n"
"\\rFirst, you should restore your Pokémon to full health.\n"
"\\rFirst, you should restore your Pokémon to full health.\n"
"\\w[signskin]Once you save your game, you can access the Mystery Gift.\n"
"\\w[signskin]Once you save your game, you can access the Mystery Gift.\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.