import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\\\(?:xn|[brw]))*([^\\r\\n]+)\\r?\\n";
final String string = "\\xn[Lan]Allez, il faut se dépécher, RED !\n"
+ "\\xn[Lan]Allez, il faut se dépécher, RED !\n"
+ "\\bI'll stay here, then\n"
+ "\\rFirst, you should restore your Pokémon to full health.\n"
+ "\\rFirst, you should restore your Pokémon to full health.\n"
+ "\\w[signskin]Once you save your game, you can access the Mystery Gift.\n"
+ "\\w[signskin]Once you save your game, you can access the Mystery Gift.\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}