#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)ZZ=\d+.+XXX.+"
Local $sString = "HH=101 " & @CRLF & _
"OO" & @CRLF & _
"XXX " & @CRLF & _
"111111111111" & @CRLF & _
"222222222222" & @CRLF & _
"" & @CRLF & _
"00000000000" & @CRLF & _
"AAAAAAAAAAAA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")