$re = '/ZZ=\d+.+XXX.+/s';
$str = 'HH=101
OO
XXX
111111111111
222222222222
00000000000
AAAAAAAAAAAA';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);