using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ZZ=\d+.+XXX.+";
string input = @"HH=101
OO
XXX
111111111111
222222222222
00000000000
AAAAAAAAAAAA";
RegexOptions options = RegexOptions.Singleline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}