re = /ZZ=\d+.+XXX.+/
str = 'HH=101
OO
XXX
111111111111
222222222222
00000000000
AAAAAAAAAAAA'
# Print the match result
str.match(re) do |match|
puts match.to_s
end