import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ZZ=\\d+.+XXX.+";
final String string = "HH=101 \n"
+ "OO\n"
+ "XXX \n"
+ "111111111111\n"
+ "222222222222\n\n"
+ "00000000000\n"
+ "AAAAAAAAAAAA";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}