#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*?(\d{1,2}-\d{1,2}-\d{2}(?:\d{2})?)){2}"
Local $sString = ""1-8-2018 en 1-2-2019" & @CRLF & _
""26-3-19 en 23-4-2019" & @CRLF & _
""1-1-20 of 8-2-20 en dan 12-10-20"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")