$re = '`^(?:.*?(\d{1,2}-\d{1,2}-\d{2}(?:\d{2})?)){2}`m';
$str = '"1-8-2018 en 1-2-2019
"26-3-19 en 23-4-2019
"1-1-20 of 8-2-20 en dan 12-10-20';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);