package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*?(\d{1,2}-\d{1,2}-\d{2}(?:\d{2})?)){2}`)
var str = `"1-8-2018 en 1-2-2019
"26-3-19 en 23-4-2019
"1-1-20 of 8-2-20 en dan 12-10-20`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}