const regex = new RegExp('^(?:.*?(\\d{1,2}-\\d{1,2}-\\d{2}(?:\\d{2})?)){2}', 'gm')
const str = `"1-8-2018 en 1-2-2019
"26-3-19 en 23-4-2019
"1-1-20 of 8-2-20 en dan 12-10-20`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}