using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:.*?(\d{1,2}-\d{1,2}-\d{2}(?:\d{2})?)){2}";
string input = @"""1-8-2018 en 1-2-2019
""26-3-19 en 23-4-2019
""1-1-20 of 8-2-20 en dan 12-10-20";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}