# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(#{1,6}\s*[\S]+)/<b>$1<\/b>/gm;t' <<< "#heading 1
bla bla bla
### heading 3 djdjdj
bla bla bla
## heading 2 bal;kasddfas
fbla bla bla"