const regex = /^(#{1,6}\s*[\S]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(#{1,6}\\s*[\\S]+)', 'gm')
const str = `#heading 1
bla bla bla
### heading 3 djdjdj
bla bla bla
## heading 2 bal;kasddfas
fbla bla bla`;
const subst = `<b>$1</b>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);