// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(#{1,6}\s*[\S]+)").unwrap();
let string = "#heading 1
bla bla bla
### heading 3 djdjdj
bla bla bla
## heading 2 bal;kasddfas
fbla bla bla";
let substitution = "<b>$1</b>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}