use strict;
my $str = '#heading 1
bla bla bla
### heading 3 djdjdj
bla bla bla
## heading 2 bal;kasddfas
fbla bla bla';
my $regex = qr/^(#{1,6}\s*[\S]+)/mp;
my $subst = '<b>$1</b>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";