$re = '/^(#{1,6}\s*[\S]+)/m';
$str = '#heading 1
bla bla bla
### heading 3 djdjdj
bla bla bla
## heading 2 bal;kasddfas
fbla bla bla';
$subst = "<b>$1</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;