#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)\bStack Overflow\b(?:[^\.]*\.){2}"
Local $sString = "Stack Overflow" & @CRLF & _
"" & @CRLF & _
"It is great website. It works very well.Lot of people help each other." & @CRLF & _
"" & @CRLF & _
"I love it."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")