const regex = new RegExp('\\bStack Overflow\\b(?:[^\\.]*\\.){2}', 'gms')
const str = `Stack Overflow
It is great website. It works very well.Lot of people help each other.
I love it.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}