package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)\bStack Overflow\b(?:[^\.]*\.){2}`)
var str = `Stack Overflow
It is great website. It works very well.Lot of people help each other.
I love it.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}