# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(file\s)([A-Za-z]+(?=\\/|\s))(.*)(\d{3})//gm;t' <<< "file Science/Chemistry/Quantum 444 1
file Marvel/CaptainAmerica 342 0
file DC/JusticeLeague/Superman 300 0
file Math 333 0
file Biology 224 1"