$re = '/(file\s)([A-Za-z]+(?=\/|\s))(.*)(\d{3})/m';
$str = 'file Science/Chemistry/Quantum 444 1
file Marvel/CaptainAmerica 342 0
file DC/JusticeLeague/Superman 300 0
file Math 333 0
file Biology 224 1';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;