using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(file\s)([A-Za-z]+(?=\/|\s))(.*)(\d{3})";
string substitution = @"";
string input = @"file Science/Chemistry/Quantum 444 1
file Marvel/CaptainAmerica 342 0
file DC/JusticeLeague/Superman 300 0
file Math 333 0
file Biology 224 1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}