#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<phone>\(\+\d{3}\)\d{9})"
Local $sString = "A new attendee has registered to your webinar:" & @CRLF & _
"" & @CRLF & _
"Webinar: מחסלת הסוכר - הילה בן עמרם" & @CRLF & _
"Webinar event date: Wednesday, July 24 2024 4:00 PM Jerusalem, Tel Aviv, Nairobi GMT +3" & @CRLF & _
"Attendee email: emilyjubran@gmail.com" & @CRLF & _
"Attendee name: Emily" & @CRLF & _
"Attendee phone: (+972)502240215" & @CRLF & _
"" & @CRLF & _
"If you want to stop receiving these notifications, you may do so by disabling new registrant notifications for this webinar in your WebinarJam account."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")