re = /(?<phone>\(\+\d{3}\)\d{9})/m
str = 'A new attendee has registered to your webinar:
Webinar: מחסלת הסוכר - הילה בן עמרם
Webinar event date: Wednesday, July 24 2024 4:00 PM Jerusalem, Tel Aviv, Nairobi GMT +3
Attendee email: emilyjubran@gmail.com
Attendee name: Emily
Attendee phone: (+972)502240215
If you want to stop receiving these notifications, you may do so by disabling new registrant notifications for this webinar in your WebinarJam account.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end