import re
regex = re.compile(r"(?<phone>\(\+\d{3}\)\d{9})", flags=re.MULTILINE)
test_str = ("A new attendee has registered to your webinar:\n\n"
"Webinar: מחסלת הסוכר - הילה בן עמרם\n"
"Webinar event date: Wednesday, July 24 2024 4:00 PM Jerusalem, Tel Aviv, Nairobi GMT +3\n"
"Attendee email: emilyjubran@gmail.com\n"
"Attendee name: Emily\n"
"Attendee phone: (+972)502240215\n\n"
"If you want to stop receiving these notifications, you may do so by disabling new registrant notifications for this webinar in your WebinarJam account.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")