use strict;
my $str = 'A new attendee has registered to your webinar:
Webinar: מחסלת הסוכר - הילה בן עמרם
Webinar event date: Wednesday, July 24 2024 4:00 PM Jerusalem, Tel Aviv, Nairobi GMT +3
Attendee email: emilyjubran@gmail.com
Attendee name: Emily
Attendee phone: (+972)502240215
If you want to stop receiving these notifications, you may do so by disabling new registrant notifications for this webinar in your WebinarJam account.';
my $regex = qr/(?<phone>\(\+\d{3}\)\d{9})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}