// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<phone>\(\+\d{3}\)\d{9})").unwrap();
let string = "A new attendee has registered to your webinar:
Webinar: מחסלת הסוכר - הילה בן עמרם
Webinar event date: Wednesday, July 24 2024 4:00 PM Jerusalem, Tel Aviv, Nairobi GMT +3
Attendee email: emilyjubran@gmail.com
Attendee name: Emily
Attendee phone: (+972)502240215
If you want to stop receiving these notifications, you may do so by disabling new registrant notifications for this webinar in your WebinarJam account.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}