#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(vue? d[ée]gag[ée]|vue? (d'?)?exception([a-z]+)?|vue? panoramique|vue? 360|sans vis [aà] vis)"
Local $sString = "avec vue dégagée" & @CRLF & _
"avec vue degagee" & @CRLF & _
"" & @CRLF & _
"superbe vue dégagée" & @CRLF & _
"une belle vue dégagée" & @CRLF & _
"bénéficient d'une vue dégagée" & @CRLF & _
"terrasse offrant une vue dégagée" & @CRLF & _
"terrasse privative avec vue dégagée" & @CRLF & _
"terrasses avec vue dégagée" & @CRLF & _
"bureaux avec vue dégagée" & @CRLF & _
"bénéficie en façade d'une vue dégagée" & @CRLF & _
"surface bénéficie une vue dégagée" & @CRLF & _
"" & @CRLF & _
"vue dégagée et sans vis à vis" & @CRLF & _
"rdc lumineux sans vis à vis" & @CRLF & _
"local sans vis a vis" & @CRLF & _
"" & @CRLF & _
"avec une vue d'exception" & @CRLF & _
"avec une vue dexception" & @CRLF & _
"vue exceptionnelle" & @CRLF & _
"" & @CRLF & _
"offrent une vue panoramique" & @CRLF & _
"lumineux vue panoramique" & @CRLF & _
"bénéficie d’une vue panoramique" & @CRLF & _
"dispose d'une vue panoramique" & @CRLF & _
"offre une vu panoramique" & @CRLF & _
"rooftop paysagé avec vue panoramique" & @CRLF & _
"" & @CRLF & _
"vue 360° en rooftop"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")