const regex = /(vue? d[ée]gag[ée]|vue? (d'?)?exception([a-z]+)?|vue? panoramique|vue? 360|sans vis [aà] vis)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(vue? d[ée]gag[ée]|vue? (d\'?)?exception([a-z]+)?|vue? panoramique|vue? 360|sans vis [aà] vis)', 'gm')
const str = `avec vue dégagée
avec vue degagee
superbe vue dégagée
une belle vue dégagée
bénéficient d'une vue dégagée
terrasse offrant une vue dégagée
terrasse privative avec vue dégagée
terrasses avec vue dégagée
bureaux avec vue dégagée
bénéficie en façade d'une vue dégagée
surface bénéficie une vue dégagée
vue dégagée et sans vis à vis
rdc lumineux sans vis à vis
local sans vis a vis
avec une vue d'exception
avec une vue dexception
vue exceptionnelle
offrent une vue panoramique
lumineux vue panoramique
bénéficie d’une vue panoramique
dispose d'une vue panoramique
offre une vu panoramique
rooftop paysagé avec vue panoramique
vue 360° en rooftop`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}