import re
regex = re.compile(r"(vue? d[ée]gag[ée]|vue? (d'?)?exception([a-z]+)?|vue? panoramique|vue? 360|sans vis [aà] vis)", flags=re.MULTILINE)
test_str = ("avec vue dégagée\n"
"avec vue degagee\n\n"
"superbe vue dégagée\n"
"une belle vue dégagée\n"
"bénéficient d'une vue dégagée\n"
"terrasse offrant une vue dégagée\n"
"terrasse privative avec vue dégagée\n"
"terrasses avec vue dégagée\n"
"bureaux avec vue dégagée\n"
"bénéficie en façade d'une vue dégagée\n"
"surface bénéficie une vue dégagée\n\n"
"vue dégagée et sans vis à vis\n"
"rdc lumineux sans vis à vis\n"
"local sans vis a vis\n\n"
"avec une vue d'exception\n"
"avec une vue dexception\n"
"vue exceptionnelle\n\n"
"offrent une vue panoramique\n"
"lumineux vue panoramique\n"
"bénéficie d’une vue panoramique\n"
"dispose d'une vue panoramique\n"
"offre une vu panoramique\n"
"rooftop paysagé avec vue panoramique\n\n"
"vue 360° en rooftop")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")