using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/([\w\.\-_]+\.?[\w]+)(\?.*)?$";
string input = @"https://site.ru/css/css.css?73486438
https://site.ru/images/favicon.ico";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}