const regex = /\/([\w\.\-_]+\.?[\w]+)(\?.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/([\\w\\.\\-_]+\\.?[\\w]+)(\\?.*)?$', 'gm')
const str = `https://site.ru/css/css.css?73486438
https://site.ru/images/favicon.ico`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}