re = /\/([\w\.\-_]+\.?[\w]+)(\?.*)?$/m
str = 'https://site.ru/css/css.css?73486438
https://site.ru/images/favicon.ico'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end