package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/([\w\.\-_]+\.?[\w]+)(\?.*)?$`)
var str = `https://site.ru/css/css.css?73486438
https://site.ru/images/favicon.ico`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}