$re = '/\/([\w\.\-_]+\.?[\w]+)(\?.*)?$/m';
$str = 'https://site.ru/css/css.css?73486438
https://site.ru/images/favicon.ico';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);