package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\n]+\n(ААА)(\r?\n[^\n]+){2}`)
var str = `111
222
333
ААА
444
555
666`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}