const regex = /[^\n]+\n(ААА)(\r?\n[^\n]+){2}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\n]+\\n(ААА)(\\r?\\n[^\\n]+){2}', 'gm')
const str = `111
222
333
ААА
444
555
666`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);