import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\n]+\\n(ААА)(\\r?\\n[^\\n]+){2}";
final String string = "111\n"
+ "222\n"
+ "333\n"
+ "ААА\n"
+ "444\n"
+ "555\n"
+ "666";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}